[C++-sig] Re: -sBUILD=debug-python

David Abrahams dave at boost-consulting.com
Tue Nov 23 23:15:26 CET 2004

Stefan Quandt <Stefan.Quandt at bardenheuer.de> writes:

D> David Abrahams wrote:
>> Stefan Quandt <Stefan.Quandt at bardenheuer.de> writes:
>>>>> Hmm.
>>>>> I'm trying again to reproduce your problem here.  Maybe by comparing
>>>>> our bjam output we can learn something.  FYI, I am going into
>>>>> boost/libs/python/example and running
>>>>>   bjam -d+2 -sTOOLS=vc-7_1 -sBUILD=debug-python test1
>>> I did the same.
>>> The resulting boost_python.dll was linked against the NON DEBUG version
>>> python23.dll.
>>> I modified three lines in Jamrules like below:
>>> PYTHON_VERSION = 2.3 ;
>>> PYTHON_ROOT = C:/Python-2.3.4 ;
>>> TOOLS = msvc ;
>>> I send you bjam output as attachment.
>>> You will see that the "-DBOOST_PYTHON_DEBUGGING" is missing in the
>>> compiler command lines!
>> -DBOOST_PYTHON_DEBUGGING is never supposed to be in a command line.
>> I think you mean -DBOOST_DEBUG_PYTHON.
> Yes.
>>> I used MS VC6, boost_1_32_0 and bjam built from the sources.
>> Sorry, but either you didn't include the complete output, or there's
>> no way you did the same, because no extension is being built.  In
>> fact, it never even tries to link boost_python.dll.  What directory of
>> your Boost tree were you in, and exactly what command line did you
>> issue to get this result?
> Sorry, I interrupted the build because of the missing
> Logs of a complete log encloesd.
> Build directory: boost_1_32_0\libs\python\example
> Build command: bjam -d+2 -sBUILD=debug-python test1

I'm without a clue. Do the results look the same with 

   -n -sTOOLS=vc-7_1


Dave Abrahams
Boost Consulting

More information about the Cplusplus-sig mailing list