[C++-sig] VC 2005 support in boost.python

Henry Padilla padilla.henry at gmail.com
Fri Apr 28 19:52:51 CEST 2006


The specific error we get is "error C2665:
'boost::**python::detail::make_getter'
: none of the 3 overloads could convert all the argument types".

Don't know if this is fixed and compatible with the Civ4 SDK.

Tom P.




On 4/28/06, Paul F. Kunz <Paul_Kunz at slac.stanford.edu> wrote:
>
> >>>>> On Fri, 28 Apr 2006 13:21:28 -0400, "Henry Padilla" <
> padilla.henry at gmail.com> said:
>
> > I play Civilization 4, that uses Boost.  We can't compile the SDK
> > because there's some incompatibility issues with VC 2005.
>
> > I was wondering if anyone still had incompatibility issues with VC
> > 2005 or if the macro BOOST_WORKAROUND was still needed.
>
> > Thanks for the help.  Tom P.
>
>   At least for me, the Boost.Python libraries work with VC 2005.
>
> _______________________________________________
> C++-sig mailing list
> C++-sig at python.org
> http://mail.python.org/mailman/listinfo/c++-sig
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/cplusplus-sig/attachments/20060428/1cbd9603/attachment.htm>


More information about the Cplusplus-sig mailing list