[C++-sig] installing boost python on osx fails with non-system python

Evert evert.rol at gmail.com
Wed Jan 14 16:30:27 CET 2009

 Hi all,

I'm trying to install boost python on my mac. I initially tried
installing through macports, but that failed (see also

Thinking that it might be something in boost (+python) itself, I tried
to manually install boost, using the macports python (version 2.5.4).
But that fails as well: the libboost_python-mt.dylib library still has
/System/Library/Frameworks/Python.framework/Versions/2.5/Python as
dependency (which is also the result when installing through macports,
as mentioned in the above link).

Using "brute force", I moved
/System/Library/Frameworks/Python.framework, so that it cannot be
picked up. Unfortunately, the macports version (living in
/opt/local/Library/<etc>) is still not picked up; as a result, the
dynamic library is simply not built with this "hack".  I have
specified --with-python and even --with-python-root pointing to the
macports installation, without any luck.

The last thing I could think of was something hardcoded, and the best I 
could find was in ./tools/build/v2/tools/python.jam, where it somewhere reads 
    local prefix
      = [ GLOB /System/Library/Frameworks /Library/Frameworks
          : Python.framework ] ;
But changing that to include /opt/local/Library/Frameworks (as a wild guess) 
didn't work either.

Perhaps this issue is more related to the macports Python installation
than to boost python (some search results on this results hint in that
direction), but at the moment, I'm running out of ideas.  If anyone
has a suggestion, or familiar situations (or, eg, a positive build
result with yet another Python version), that's most welcome.

Ah yes, and the system information: mac os 10.5, G5 PPC (64
bit). Hopefully that isn't relevant here though.


More information about the Cplusplus-sig mailing list