[C++-sig] cannot find -lboost_python after upgrade to Ubuntu 9.10

Dane Springmeyer blake at hailmail.net
Sun Nov 1 23:52:58 CET 2009


I think that recent boost packages on ubuntu have added a '-py25' or '- 
py26' at the end of the library, essentially providing two libraries  
linked to each of the python versions available on ubuntu.

Dane

On Nov 1, 2009, at 2:28 PM, Anders Wallin wrote:

> This example from the tutorial
> http://pastebin.ca/1652154
>
> used to compile on my 9.04 system with this makefile:
> http://pastebin.ca/1652155
>
> now after the 9.10 upgrade I get:
> /usr/bin/ld: cannot find -lboost_python
>
>
> what could be wrong?
> I do have 'libboost-python-dev' installed as well as
> 'libboost-python1.38.0' and 'libboost1.38-dev'
> _______________________________________________
> Cplusplus-sig mailing list
> Cplusplus-sig at python.org
> http://mail.python.org/mailman/listinfo/cplusplus-sig



More information about the Cplusplus-sig mailing list