[C++-sig] ubuntu/gcc/gccxml

Nathan Stewart swarfrat at gmail.com
Mon Mar 15 20:18:02 CET 2010

I'm trying to use pyplusplus, and I'm running into what appears to be a
really old problem fixed by the gccxml-0.9.0+cvs20080525 patch.

I'm running Ubuntu 9.10, gcc-4.4.1, gccxml 0.9.0+cvs20080525. I'm also a
little confused by the various versions of gccxml out there - the 'official'
site claims 0.6 is the latest. The language-binding.net site refers to
version 0.9. Basically pyplusplus has never worked (out of the box or with
any amount of fiddling) on karmic for me, on any of my machines.

The errors I get are:

Error occured while running GCC-XML: In file included from
And lots more errors in fctnl2.h ' __builtin_va_arg_pack_len' not declared
in this scope.

I have tried running GCC-XML w/ gcc-4.2, modifying headers as in some of the
other posts, to no avail.

Is there anyone with a Karmic box that has this working at all?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/cplusplus-sig/attachments/20100315/cfbb22a4/attachment.html>

More information about the Cplusplus-sig mailing list