[Cython] Bug in cython-mode.el under GNU Emacs 23.2.1

Vitja Makarov vitja.makarov at gmail.com
Tue Mar 22 06:21:46 CET 2011

2011/3/22 Rafe Kettler <rafe.kettler at gmail.com>:
> I've just tried out cython-mode.el and I was a bit disappointed when it
> didn't work right off the bat.
> I added the following to my .emacs:
> (setq load-path (cons "~/lib/emacs-plugins" load-path))
> (require 'cython-mode)
> this initially gave me the following error when I restarted emacs:
>     Warning (initialization): An error occurred while loading
> `/home/rafe/.emacs':
>     File error: Cannot open load file, python-mode
>     To ensure normal operation, you should investigate and remove the
>     cause of the error in your initialization file.  Start Emacs with
>     the `--debug-init' option to view a complete error backtrace.
> So, seeing that python-mode wasn't around, I changed line 3 of
> cython-mode.el from (require 'python-mode) to (require 'python) and
> everything works now.
> I got this mode from Github this morning and it is the latest version (you
> can see it at
> https://github.com/cython/cython/blob/master/Tools/cython-mode.el).
> I'm not an emacs lisp expert, so I'm not sure if there's something I'm
> missing here or if I somehow loaded the package correctly. Anyway, I thought
> you guys should know that I had a problem with the file but managed to get a
> fix. If my fix needs to be applied, I'll patch it on Github.
> This is GNU Emacs 23.2.1 x64 on Fedora 14, btw.
> Rafe

Emacs23 have native support for python, you can install python-mode package:

$ sudo apt-get install python-mode

Instead of requiring python it's better to try python-mode first then python:

(when (not (require 'python-mode nil t))
  (require 'python))


More information about the cython-devel mailing list