[Cython] test failure for cython-devel in Py2.4

Vitja Makarov vitja.makarov at gmail.com
Sat Oct 15 11:17:12 CEST 2011

2011/10/15 Vitja Makarov <vitja.makarov at gmail.com>:
> 2011/10/15 Stefan Behnel <stefan_ml at behnel.de>:
>> Stefan Behnel, 13.10.2011 21:22:
>>> Vitja Makarov, 13.10.2011 20:33:
>>>> But py3k pyregr is no red due to SIGSEGV, is that python problem:
>>>> https://sage.math.washington.edu:8091/hudson/job/cython-devel-tests-pyregr/BACKEND=c,PYVERSION=py3k/26/console
>>> Not sure, but rather likely. The PEP393 implementation is still being
>>> worked on. That also makes it still a moving target to which the current
>>> code in Cython may not fit exactly. Worth investigating. I'll see if I
>>> find
>>> a bit of time for updating my local py3k installation this weekend to run
>>> some tests with it.
>> Given that the benchmark runs with the optimised CPython build still work,
>> my guess is that this is a problem only with the debug builds of CPython,
>> which we use in all test runs (and for good reason...).
> It's something wrong with py2.7 pyregr build "'exec' currently
> requires a target mapping (globals/locals)"
> is still there after you merged my exec/eval branch. I can't reproduce
> it on localhost, actually it works just fine, I tried test_binop

Right. That build was triggered by previous commits:

Pyregr shows regression from 11876 -> 11596 for last 3 builds


More information about the cython-devel mailing list