[Cython] can we deprecate for-from loops?

Jeroen Demeyer jdemeyer at cage.ugent.be
Sun Oct 11 16:01:58 EDT 2015


On 2015-10-11 16:30, Stefan Behnel wrote:
> Hi!
>
> The syntax construct "for i from 0 <= i < 10" has been silently outdated
> for years. Can we start issuing a warning that normal range() loops are
> preferred?

Is there anything wrong with the for ... from ... syntax? In more 
complicated situations I find

for i from a <= i < b by s

more readable than the equivalent for i in range() statement.

I know it's not a strong argument, it's just something to keep in mind.



More information about the cython-devel mailing list