[Datetime-SIG] Slightly better name for fold?

Alexander Belopolsky alexander.belopolsky at gmail.com
Thu Aug 27 00:13:18 CEST 2015

On Wed, Aug 26, 2015 at 6:02 PM, Alexander Belopolsky <
alexander.belopolsky at gmail.com> wrote:

> On Wed, Aug 26, 2015 at 4:54 PM, jon <jcronin at egh.com> wrote:
>> “fold” -> “folded”?
>> “fold” strikes me as imperative, rather than descriptive.
> Note that "fold" is a noun, not a verb in the context of PEP 495.  Think
> of a bifold wallet as consisting of two "folds" rather than a piece of
> leather folded once.

Using a noun for the name of an attribute is in-line with the current
naming scheme:

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/datetime-sig/attachments/20150826/53fe288f/attachment.html>

More information about the Datetime-SIG mailing list