[DB-SIG] Re: Python and Oracle

Aaron Watters aaron@cs.rutgers.edu
Wed, 11 Feb 1998 18:28:45 -0500

Hi: I thought I'd pass this to the db-sig in case any of you db folks
missed it on the big list.

I'm having a similar problem with /product/8.0.3/lib but my mystery
symbol is skgupec.  Please help us aarons!  -- Aaron Watters

Subject:      Re: Python and Oracle
From:         aaron@infinity.com
Date:         1998/02/10
Message-ID:   <887076525.608567297@dejanews.com>
Newsgroups:   comp.lang.python
[More Headers]

Hi --

We ran into the same error as you did (unable to allocate memory on user
side) when trying to use the python oracledb module with an oracle8

We tried re-building the python oracledb module against the new set of
oracle8 libraries and header files, and we then re-ran our test case.

Unfortunately, *this* time around, we weren't even able to import the
oracledb module!  We got a symbol relocation error -- the Oracle8
sharedLib libclntsh.so.1.0 was looking for the symbol "slpmprodstab".  We
couldn't seem to find this symbol anywhere!

2 questions: have you made any progress since December using Oracle8 with
Python.  In particular, have you solved the "memory allocation" error you
were seeing?  And have you run into the run-time linking error that we're
seeing?  We would appreciate greatly any insight you have on this!


Aaron Hallmark

DB-SIG  - SIG on Tabular Databases in Python

send messages to: db-sig@python.org
administrivia to: db-sig-request@python.org