[DB-SIG] DCOracle on HP-UX 11.00 using Oracle 8.1.5

Gerhard Gonter gonter@maestria.wu-wien.ac.at
Wed, 19 Apr 2000 18:57:13 +0200 (MES)

> Return-path:  <j.andrusaitis@konts.lv>
> To:  <db-sig@python.org>
> Date:  Wed, 19 Apr 2000 16:52:37 +0300
> Subject:  [DB-SIG] DCOracle on HP-UX 11.00 using Oracle 8.1.5

> Has anyone successfully used DCOracle module on HP-UX 11.00 with Oracle
> 8.1.5?
> I managed to compile it statically into Python and stangely it actually
> worked (at least I was able to fetch some rows:).

A similar problem:  Does anybody know what the correct setup is to
produce a shared module on AIX 4.2 for Oracle 7.3.4?

I tried to find a solution for several days and finally hacked a Perl
script (sorry, I'm not fluent enough in Python yet) that tried several
configurations for a night until it evenutally spit out a shared object
that actually works.

There must be a better way instead of this brute force method.  Any

Gerhard.Gonter@wu-wien.ac.at  Fax: +43/1/31336/702  g.gonter@ieee.org
Zentrum fuer Informatikdienste, Wirtschaftsuniversitaet Wien, Austria