[DB-SIG] "Freezing" MX applications

Schollnick, Benjamin Benjamin.Schollnick@usa.xerox.com
Fri, 11 May 2001 09:08:57 -0400

I'm running into a big problem here...

With Python 2.0, and the mx package(s) - mx-base v2.0.1 & mx-commercial -
2.0.2, both Gordon McMillon's Installer (v4.1a) and py2exe (v0.26) are

mx.DateTime is being "archived", but mx.ODBC (& children) are not being
captured for archiving....

Has anyone had any success with these packages?

Previously with python v1.52 and a previous installer (mcMillon), I was able
to get this to work.... But the lazy module has changed, and is seemingly
defeating all the packages...

Is there anyway to stop the lazy loads?  I tried editting the __init__.py in
the ODBC directory and started to get crashes (GPF/Dr.Watson's) when the
application finished.... (Everything worked fine, until the program

		- Benjamin

The py2exe problem maybe simple, I haven't used distutils before, and can't
seem to get the package line (when in the setup function) to work...

When the commented package line is in the setup function, it reports that mx
isn't a package?

#!/usr/bin/env python

from distutils.core import setup
import py2exe

      description="Homepage Viewer",
      author="Benjamin Schollnick",
      scripts = ["viewer.py"],

#      packages=['mx', 'mx.ODBC', 'mx.DateTime'],