[DB-SIG] MS SQL Server and odbc getting 'None'

M.-A. Lemburg mal at egenix.com
Sat Aug 14 12:53:47 CEST 2004

Carey David SSgt 109CF/SCBJ wrote:
> Thanks for the suggestion! I will take a look at it. mxODBC worked when
> pulling the information, but when I tried to update or insert records, it
> would act like it worked. Then when I went to the database nothing changed.

You most probably forgot to commit your changes (call .commit()
on the connection object). Unlike most ODBC command line tools,
mxODBC does not default to auto-commit mode, since using transactions is 
always better than making permanent changes to the database right away.

Marc-Andre Lemburg

Professional Python Software directly from the Source
 >>> Python/Zope Consulting and Support ...        http://www.egenix.com/
 >>> mxODBC.Zope.Database.Adapter ...             http://zope.egenix.com/
 >>> mxODBC, mxDateTime, mxTextTools ...        http://python.egenix.com/

::: Try mxODBC.Zope.DA for Windows,Linux,Solaris,FreeBSD for free ! ::::

More information about the DB-SIG mailing list