[DB-SIG] mxODBC.ProgrammingError: ('37000', 8501, "[Microsoft][ODBC SQL Server Driver][SQL Server]MSDTC on server 'xxxxx' is unavailable.", 4612)

M.-A. Lemburg mal at egenix.com
Thu Nov 4 09:28:16 CET 2004

Copying the error message here:

[Microsoft][ODBC SQL Server Driver][SQL Server]MSDTC on	server 'xxxxx' is unavailable.", 4612)

Joe Goldthwaite wrote:
> I suspect I'm not going to get a happy answer on this one.  I ran into it
> during the final testing of some major structural changes in my application.
> I'm using SQL server as my database.  I had originally built some data
> tables for reporting and was storing them in the main database used by our
> JDE application.  Due to some additional requirements for other reporting
> databases, I pulled the tables out and put them in their own database on a
> separate server.  I then used Microsoft SQL servers ability to link tables
> to access the raw data from the JDE database and pull the data into the
> reporting database.
> To do this, I specify the fully qualified table name in my stored procedure.
> For example, to reference the F0901 table in the JDE_PRODUCTION database on
> our JDEENT server, I have to reference it as
> JDEENT.JDE_PRODUCTION.PRODDTA.F0901.  JDEENT is the server name,
> JDE_PRODUCTION is the database name and PRODDTA is the table owner.

Note that there's a limit on the length of column names in
SQL: mxODBC uses a 37 character limit which is what ANSI SQL
defines. I don't that's a problem here, though, since you'd get
a warning from the database in case of truncations.

> If I execute the stored procedure or one of the individual queries from
> within Microsoft's SQL Query Analyzer, it works fine.  When I try to execute
> the exact same SQL statement from the cursor.execute function, I get the
> above MSDTC error.  MSDTC stands for Microsoft Distributed Transaction
> Coordinator.
> I suspect that the MS Query Analyzer is doing something different that
> allows it to reference linked tables that the mxODBC code does not.  I'm
> hoping that someone knows about some setting or something that enables the
> use of linked tables in mxODBC.  I'm not optimistic though.  It's a bummer
> that I ran into this at the END of all my changes...

This is likely not an mxODBC problem, but related to the
configuration of DTS and your database cluster. Here are some

  * "MSDTC Is Unavailable" Error When a Stand-Alone Instance of SQL Server Is in a Cluster Environment

  * Transacted Commerce Server Pipeline Failure
	(see resolution steps 1 - 9)

  * Troubleshooting Guides for SQL Server

Marc-Andre Lemburg

Professional Python Services directly from the Source  (#1, Nov 04 2004)
 >>> Python/Zope Consulting and Support ...        http://www.egenix.com/
 >>> mxODBC.Zope.Database.Adapter ...             http://zope.egenix.com/
 >>> mxODBC, mxDateTime, mxTextTools ...        http://python.egenix.com/

::: Try mxODBC.Zope.DA for Windows,Linux,Solaris,FreeBSD for free ! ::::

More information about the DB-SIG mailing list