[DB-SIG] FW: pep 249 (ImportError python libifsql.so)

Gulati, Anil a.gulati at tsc.nsw.edu.au
Tue Jul 8 01:43:01 CEST 2008

Issue resolved!


LD_LIBRARY_PATH seems to need to be set in /etc/profile. I was only
setting it in the shell that I was running the test from.


Fixing that immediately changed the error message. Then I just needed to
find out about SQLHOSTS file and the service entry in /etc/services and
the INFORMIXSERVER variable. It seems hard to find this information in
the IBM Informix documentation.


Now that all these are set up I am now retrieving data from Informix on
Red Hat Linux, and running Python scripts to do so!


Thanks very much for your feedback and for being available.


Anil Gulati



From: Gulati, Anil 
Sent: Monday, 7 July 2008 12:18 PM
To: 'Carsten Haese'
Subject: RE: FW: pep 249 (ImportError python libifsql.so)


Thanks for your rapid reply, Carsten...


That's very nice of you to offer help on these basic installation
problems for the IBM installation.


All the files are owned by Informix user in Informix group.

All files are either rwxr-xr-x or rw-r--r--, directories with x of

The .so files have execute but the .a files don't.

Everything is world readable all the way up to / so I don't see a
problem there.


Yes, the LD_LIBRARY_PATH was all lower case! My (unmentionable) email
client likes to munge stuff for me when I'm not expecting it.


This is a totally new box and this is the first install of IBM Informix,
so there is no contamination anywhere.

I have just re-installed from the same download taking careful note of
the options and logging and got the same result.

I also did a rm -rf on /usr/local/informix prior to re-installing, which
seems to be the IBM recommended uninstall operation.


I am thinking of

*	checking if there is a different version I should be installing
*	re-downloading the installer anyway and trying again fresh
*	if there is a different environment variable that needs setting
with the library paths
*	trying a static library install (.a only)





From: Carsten Haese [mailto:carsten.haese at gmail.com] 
Sent: Monday, 7 July 2008 11:28 AM
To: Gulati, Anil
Subject: Re: FW: pep 249 (ImportError python libifsql.so)


On Sun, Jul 6, 2008 at 8:58 PM, Gulati, Anil <a.gulati at tsc.nsw.edu.au>

	Ah, just noticed the maintainer addresses in the README...
	Also found I get the same error when running Informix ESQL/C
Client demo
	In /usr/local/informix/demo/esqlc
	$ make demo1
	$ ./demo1
	error while loading shared libraries: libifsql.so: cannot open
	object file: No such file or directory
	Sorry, it seems this has nothing to do with the Python layer.
	The Informix client itself is not finding it's own libraries in
	I tried using export
	But to no avail.

The error message means either that the dynamic linker can't *find* the
library or that it can't *read* the library. That in turn is usually
caused by an incorrect or corrupted installation of the Client SDK, or
by an incorrect setting of the library path. If the above is *exactly*
what you set LD_LIBRARY_PATH to, that may be your problem right there,
since Unix-like OSes are case-sensitive, and you have informix spelled
with a lowercase "i" in one case and with an uppercase "I" in the other.

If this is just a transcription error and you actually did set
LD_LIBRARY_PATH correctly, the next thing I'd check is whether the
libraries are where you say they are and whether their permissions are
set to rwxr-xr-x, and whether the permissions of the parent directories
are sufficiently open.

It's also possible that you accidentally corrupted your installation,
for example by installing a 32bit CSDK on top of it. If all else fails,
try to carefully reinstall the 64bit CSDK in /usr/local/informix.

Hope this helps,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/db-sig/attachments/20080708/7168d922/attachment.htm>

More information about the DB-SIG mailing list