[DB-SIG] Help on ImportError:DLL load failed ...

Dieter Maurer dieter at handshake.de
Thu Jan 7 14:20:26 CET 2010


Sumant Kuchipudi wrote at 2010-1-6 09:24 -0500:
>I was struggling with an error "ImportError: DLL load failed: The specified
>procedure could not be found." when I call import cx_Oracle module. I'm
>using Python 2.6 and for Oracle 11g, I've installed cx_Oracle 5.0.2 (also
>tried 5.0.1 and 5.0). I tried in google for help but no use, I found your
>question in mailing list forum, I think you definitely found the solution
>and expecting you the person will give my solution.

Usually, errors like this are caused by version problems.
Somehow, the DLL does not fit the rest.

To analyse such errors, you must determine which DLL could not be loaded
and which symbol makes problems.

The first information can usually be determined from the
Python traceback. It tells you in which calling and code context
an exception occured. The last line is especially relevant, it
tells the place where the exception occured. Preceeding lines tell
how you came there.


The message looks like generated from an MS operating system.
MS operating systems have the unfortunate tendancy not to name things
in their problem describing messages: as above
"some procedure" rather than "procedure XXX".
I do not know how to find out under MS which symbol has problems.
Maybe, you find something in the MS documentation (which is said
to be good).

Maybe, we already learn enough from the traceback....




-- 
Dieter


More information about the DB-SIG mailing list