[DB-SIG] Having legs into diffents PostgreSQL versions?!?

Joshua D. Drake jd at commandprompt.com
Sat Jan 16 18:30:58 CET 2010

On Sat, 2010-01-16 at 09:59 +0100, Massa, Harald Armin wrote:
> hey,
> > Well I mean having piece of code reading and writing db records from 7.2 and
> > 8.4 databases.
> >
> > How can I get this mix working from a DBAPI point of view?
> > Are someone aware of restrictions using such 'old' db drivers from Python
> > 2.6 or later?
> per definition the actual PostgreSQL driver shall be able to access
> also ancient versions of PostgreSQL; and you should also be able to
> profit from at least some of the bugfixes within the PostgreSQL
> connection libraries of the last oneandahalf decade.
> So: I recommend to you to go with the younges psycopg2 PostgreSQL driver.
> I also offer persuasion services to help people motivate themselfs,
> i.e. to upgrade PostgreSQL.

That is correct, if you are running an old version, PostgreSQL will just
default to the old protocol. However, I must say... the fact that you
are running 7.2 is terrifying on a level that makes me have cold sweats
and cry for mommy.

You should be running *at least* 8.3.

Joshua D. Drake

PostgreSQL.org Major Contributor
Command Prompt, Inc: http://www.commandprompt.com/ - 503.667.4564
Consulting, Training, Support, Custom Development, Engineering
Respect is earned, not gained through arbitrary and repetitive use or Mr. or Sir.

More information about the DB-SIG mailing list