[Distutils] RE: Distutils prerequisites (Greg Ward)

Lyle Johnson jlj@cfd1.cfdrc.com
Mon, 10 Apr 2000 09:10:20 -0500

> Also, what are the requirements on Windows?  AFAIK all you need to
> install the Distutils proper is Python 1.5.2 or later (keep in mind that
> I have only made 1.5.1 compat. changes to the 0.1.x code -- I still need
> to port those changes to the current code).  But to build extensions, I
> *think* it goes like this:
>   * Visual C++ 5.x or 6.x (what can x equal?)
>   * Python 1.5.x only: win32api and win32con modules recommended
>     (for registry access, which is provided by the standard
>     winreg module in Python 1.6)

Visual C++ versions 5 and 6 only had ".0" releases (no intermediate releases
like VC++ 4.2), so for your first requirement x = '0'. There are a few
service packs available for VC++ 6 but I don't believe any of them were
*required* for building Python extensions.

A little off-topic, maybe, but hopefully the Distutils will also be able to
support building Python extensions on Windows using the Mingw32 compiler
system (i.e. the Win32 "ports" of gcc and friends). I know that I've seen a
HOWTO about building Python extensions on Win32 using Mingw32 somewhere...