[Distutils] installation error on UNIX

Guido van Rossum guido@CNRI.Reston.VA.US
Tue, 01 Feb 2000 11:07:04 -0500


> >   File "distutils/command/build_py.py", line 112, in get_package_dir
> >     return apply (os.path.join, path)
> > TypeError: apply() 2nd argument must be tuple

This smells of Python version 1.5.1 or older; in 1.5.2, apply() does
allow any sequence as second arg.

--Guido van Rossum (home page: http://www.python.org/~guido/)