[Distutils] Timeframe of 2.0 again?

Mark W. Alexander slash at dotnetslash.net
Fri Oct 24 20:55:21 EDT 2003

On Fri, 24 Oct 2003, Bob Ippolito wrote:

> On Oct 24, 2003, at 4:01 PM, M.-A. Lemburg wrote:
> > Where would you want to use nested scopes in distutils code ?
> > Note that distutils code is not performance relevant. It's
> > ease of customization and wide-spread usability that
> > matters.
> >
> > You should be aware that package authors will be forced to drop
> > Python <x.y support for whatever x.y version we choose for
> > distutils. I wouldn't want to drop Python 2.1 support until
> > Python 2.3.3 is out (I plan to skip Python 2.2 altogether because
> > of the speed advantages that 2.3 has to offer :-).
> I find myself using nested scopes, generators, descriptors and new
> style classes quite a lot.  It has nothing to do with performance, it's
> capability.  There are a lot of occasions where generators can save you
> quite bit of code, provide more extensibility, or spare you from using
> threads.  I'm never going to write another Python module/extension/etc.
> that goes out of its way to be Python 2.1 compatible, my vote is for
> 2.2.1 and later.

Marc's point is that nested scopes are not necessary (although they
could be useful) in distutils itself, therefore distutils should not
require a high enough level just to be able to use nested scopes.

Speaking as an admin of a fair number of machines, I've still got 1.5.2
running around. That's mostly because they're deprecated machines, just
waiting for their last breath to give out. I would suspect, however,
that large shops have a difficult time keeping the latest and greatest
version of Python on all their machines (I do, and I do almost all admin
stuff in python). If you've got lot's of things to do, and whatever
version of Python you have installed works for everything you've
deployed, it's just not a priority to upgrade.

So my vote would be go for the _lowest_ version of Python that makes the
Distutils code "comfortable". The higher version you require, the more
package authors you alienate by _forcing_ them to drop support (or at
least distutils support) for older versions.

Mark W. Alexander
slash at dotnetslash.net

More information about the Distutils-SIG mailing list