[Distutils] Timeframe of 2.0 again?

Mark W. Alexander mwa at anonymoose.net
Mon Oct 27 22:26:09 EST 2003

On Mon, 27 Oct 2003, Michael Hudson wrote:

> "Mark W. Alexander" <slash at dotnetslash.net> writes:
> > Speaking as an admin of a fair number of machines, I've still got 1.5.2
> > running around.
> How likely are you to try to upgrade the distutils install on those
> machines?  How often do you even install new Python packages on them?
> These are the questions that matter, not whether people still *run*
> 1.5.2.

Not at all likely to upgrade the distutils, but reasonably likely to add
new packages. The problem that might arise is that I need a new package,
but the setup.py for that package is in Distutils2 format.

But as I noted, I think 1.5.2 is just something that people in my
position will have to cope with. If the need for a Distutils2 pacakge
arises, then I'd upgrade to the latest Python anyway. At 2.0 on, the
decision gets a little fuzzier.

Mark W. Alexander
slash at dotnetslash.net

More information about the Distutils-SIG mailing list