[Distutils] build_py support from setuptools

Anthony Baxter anthony at interlink.com.au
Wed Jun 9 20:26:58 EDT 2004

Fred L. Drake, Jr. wrote:
> On Wednesday 09 June 2004 12:13 am, Phillip J. Eby wrote:
>  > * The module/package support is already in distutils on the CVS HEAD, so
>  > there's nothing to do there.
> This is good; then I don't need to worry about this for the trunk.
>  > * These kinds of behavioral change/upgrades seem unlikely to be approved
>  > for 2.3.5, since the previous behavior was documented as such and
>  > therefore not a "bug".
> Hmm.  I've been thinking we generally want the latest distutils for all of the 
> maintained releases of Python.  If that's not the case, that's fine.  In that 
> case, I'll ignore the 2.3.x line since the package_data support is clearly a 
> feature (and really handy as well, thanks!).

While it would be kinda nice to have it in 2.3, it's definitely
a "new" thing, and as such should be avoided. Bear in mind 2.4
will be out before 2.3.5, anyway.

Anthony Baxter     <anthony at interlink.com.au>
It's never too late to have a happy childhood.

More information about the Distutils-SIG mailing list