[Distutils] Trouble installing Myghty with --prefix

skip@pobox.com skip at pobox.com
Thu Dec 1 00:49:57 CET 2005

    pje> 1.  Change your .pth file to read:

    pje>      import site; site.addsitedir('/usr/local/mojam/lib/python2.3/site-packages')

Did that:

    $ cat /usr/lib/python2.3/site-packages/mojam.pth
    # This file should be the only intrusion on the system-installed version of
    # python...
    import site; site.addsitedir("/usr/local/mojam/lib/python2.3/site-packages")

    pje> 2. Create a distutils.cfg in /usr/lib/python2.3/distutils/ with the 
    pje> contents I mentioned before.

Again with my desire to minimize cruft in /usr/lib/python2.3, I saw that
setuptools is supposed to honor ~/.pydistutils.cfg and created:

    $ cat ~/.pydistutils.cfg
    prefix = /usr/local/mojam

    site_dirs = /usr/local/mojam/lib/python2.3/site-packages

Then, after removing all the previously installed .egg directories and the
build directory in my Myghty source tree, I tried

    python setup.py install --prefix=/usr/local/mojam

again.  Same result.  So I suffered with creating
/usr/lib/python2.3/distutils/distutils.cfg.  Lather.  Rinse.  Repeat.  Same

    $ python
    Python 2.3.4 (#1, Feb 22 2005, 04:09:37) 
    [GCC 3.4.3 20041212 (Red Hat 3.4.3-9.EL4)] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>> import pkg_resources
    Traceback (most recent call last):
      File "<stdin>", line 1, in ?
    ImportError: No module named pkg_resources

What to try next?


More information about the Distutils-SIG mailing list