[Distutils] Naming conventions for module unit tests?

John J Lee jjl at pobox.com
Thu Dec 15 02:04:03 CET 2005

On Wed, 14 Dec 2005, Todd Greenwood-Geer wrote:
> Anyone have any good naming conventions for module tests?
> [module name]_unittest.py
> test_[module_name].py
> unittest_[module_name].py

Hmm, I actually misread your question in your original email...

Python itself uses test_[module_name].py, so I guess that's a reasonable

> Then there's the issue of differentiating unit tests from functional
> tests, scenario tests...

personally I put my functional tests in a functional_tests.py, but then I
have too few functional tests in my open source stuff...

> Perhaps:
> [aggregation]_[level]_[module].py
> 	drt_unittest_foo.py
> 	bvt_functionaltest_foo.py
> Or am I overly complicating things again?

That surely depends entirely on whether you're writing myfirstbabypackage
or some massive framework.

On the general subject of conventions, note that Barry Warsaw just
released a new PEP 8 draft (see last day or two's posts in python-dev
archives, particularly from Barry Warsaw).  python-dev is currently
discussing the momentous subject of whether function_names_like_this
should be blessed over functionNamesLikeThis, or just to give the standard
"pick one and stick to it" advice.


More information about the Distutils-SIG mailing list