[Distutils] easy_install - some thoughts

Paul Moore p.f.moore at gmail.com
Tue Jul 12 20:37:30 CEST 2005

On 7/12/05, Phillip J. Eby <pje at telecommunity.com> wrote:
> At 11:11 AM 7/12/2005 +0100, Paul Moore wrote:
> >Quick question, is there a "convert but don't install yet" option? So
> >I get an egg on my PC, but not in site-packages.
> Yes, it's called --install-dir, and you set it to the directory where you'd
> like it to dump the egg.  :)  If you don't want script wrappers in that
> directory too, use --exclude-scripts as well.  So, "easy_install -xd
> somedir pysqlite" would dump the pysqlite egg in "somedir".

Neat, thanks.

By the way, I don't know if the sqlite web page has changed, but your
standard example of sqlite doesn't work for me:

>\Apps\Python24\Scripts\easy_install.py -xd test sqlite
Searching for sqlite
Reading http://www.python.org/pypi/sqlite/
Reading http://pysqlite.org/
No local packages or download links found for sqlite
error: Could not find distribution for Requirement('sqlite', [], ())

I tried a few others - cx_Oracle, ctypes, kinterbasdb,
python-dateutil, and they didn't work either. PIL *nearly* did - it
found the PIL 1.1.5 Windows installer for Python 2.4, but it then
failed with

error: c:\docume~1\gustav\locals~1\temp\easy_install-k1vu-u\PIL-1.1.5.win32-py2.4.exe
is not a valid distutils Windows .exe

which is probably wrong, as the URL was correct and the file is a
Python installer, but I can't diagnose much further as the temp file
was deleted - could it be binary/text file issues? Actually, if I
download the file manually and do "easy_install.py -xd test
PIL-1.1.5.win32-py2.4.exe" I still get the same error, so it's deeper
than that...

I can't think of much more I can do to diagnose this for you, but let
me know if there's anything you'd like me to try.

This is with setuptools-0.5a9, btw, I haven't had time to download the
new version yet (there's no Windows installer, so I'll have to use the
egg, which shouldn't be hard but I'd rather not compound the issues by
using a mis-installed package :-))


More information about the Distutils-SIG mailing list