[Distutils] setuptools using -D on package requirements?

Phillip J. Eby pje at telecommunity.com
Fri Nov 11 21:26:45 CET 2005

At 02:52 PM 11/10/2005 -0800, Ben Bangert wrote:
>Is there a reason I can't have setuptools automatically upgrade/
>delete existing/conflicting package versions that are a 'requirement'
>for the package I want to install?
>For example, if I have the 0.3 of PasteScript installed, and run my
>own package which requires (and has the URL for) the svn dev version
>of PasteScript, here's what I get:
>% sudo python ez_setup.py -D -f http://pylons.groovie.org/ Pylons
>Reading http://pylons.groovie.org/
>Searching for Pylons
>Best match: Pylons 0.1dev-r87
>Processing Pylons-0.1dev_r87-py2.4.egg
>Pylons 0.1dev-r87 is already the active version in easy-install.pth
>Using /opt/local/Library/Frameworks/Python.framework/Versions/2.4/lib/
>Processing dependencies for Pylons
>error: Installed distribution Paste 0.3 conflicts with requirement

That's weird.  What version of setuptools are you using?  The current 
version uses a "breadth-first" dependency resolution algorithm that should 
give Pylons' dependencies precedence over those of other packages.

I tried doing your command above (adding -vv to get more detailed info), 
but I get this error instead:

No local packages or download links found for Paste>=0.4dev-r3631
error: Could not find distribution for Requirement.parse('Paste>=0.4dev-r3631')

Presumably this is because you've changed your requirements but not your 
links page.  Anyway, it shows that my local setuptools is doing the right 
thing, because it's not reporting a conflict with Paste 0.3 (which I 
installed first).  Are you using at least setuptools 0.6a6?  If not, please 
try installing the development version of setuptools, by running:

     easy_install setuptools==dev

And then try your easy_install again.

More information about the Distutils-SIG mailing list