[Distutils] [DistUtils] - Problem with versions...

Sharky On PTNet sharkypt at gmail.com
Tue Nov 29 13:51:56 CET 2005


   Trying to upgrade cherrypy pkg with ease_install, i notice that
easy_install don't detect the newer version.

   You can see that 2.1.0 is the final and not 2.1.0-rc2 in the
sourceforge page:

Thanks for all
Sharkypt @ Helio Pereira

# easy_install -U cherrypy
Searching for cherrypy
Reading http://www.python.org/pypi/cherrypy/
Couldn't find index page for 'cherrypy' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading http://www.python.org/pypi/
Reading http://www.python.org/pypi/CherryPy/2.1.0
Reading http://www.cherrypy.org
Reading http://sourceforge.net/project/showfiles.php?group_id=56099
Best match: CherryPy 2.1.0-rc2
Processing CherryPy-2.1.0_rc2-py2.4.egg
CherryPy 2.1.0-rc2 is already the active version in easy-install.pth

Using /usr/lib/python2.4/site-packages/CherryPy-2.1.0_rc2-py2.4.egg
Processing dependencies for cherrypy

More information about the Distutils-SIG mailing list