[Distutils] Using easy_install without net access

Paul Moore p.f.moore at gmail.com
Tue Apr 11 00:02:15 CEST 2006

I'm trying to install a setuptools-based package (RuleDispatch) but
there are no suitable binary eggs on the net (Python 2.5 on Windows).
So I'm effectively building all of my own eggs and installing as if I
have no net access [1]. According to

"""If you can't use APS, or don't have internet access at all, you
will need to first download the appropriate .egg file from the
setuptools PyPI page using a computer with internet access. Place the
egg in the same directory as ez_setup.py on the target computer before
running it."""

I tried this, but I can't get it to work - ez_setup.py still tries to
go to CheeseShop. Do I need some command line flags not mentioned on
the EasyInstall page? I've tried the most obvious ones, but to no

Actually, I got somewhere, by building a setuptools egg, adding it to
PYTHONPATH, then running ez_setup.py. That "installed" setuptools, but
didn't move it anywhere - it's still in my temporary "Data" directory.
>From there, easy_install -f . RuleDispatch seems to be getting
somewhere (I now need to build PyProtocols, but that's OK). But still
nothing's getting copied into site-packages.

I'm clearly doing something wrong, but I have no idea what.

At the risk of going on about it, this is far messier than the
traditional "python setup.py bdist_wininst" and run the installer...

(BTW, what I ultimately want to do is to try out RuleDispatch on a
machine which doesn't have net access. The rest is just annoying
cruft. For now, I got this by building a wininst installer for
setuptools, installing it, building wininst installers for pyprotocols
and ruledispatch, uninstalling setuptools, and then using the wininst
installers - as neither package uses setuptools at runtime...)


[1] Actually, one of the machines I'm doing this on is not (easily)
connected to the net in any case.

More information about the Distutils-SIG mailing list