[Distutils] setuptools 0.6a10/a9 conflict

Ian Bicking ianb at colorstudy.com
Tue Feb 14 23:59:20 CET 2006

I just installed setuptools 0.6a10 on a host, and that host had a copy 
of 0.6a9 in site-packages.  0.6a10 got installed into a different 
directory that had been set up like the Administrator Install 
instructions (that is, add the directory to the path in sitecustomize). 
    The site-packages (0.6a9) version had a setuptools.pth file pointing 
to it (in site-packages itself).  The new 0.6a10 also had a 
setuptools.pth file, but in a later path.

After that, when I ran easy_install it imported from the 0.6a9 
pkg_resources module, not the 0.6a10 version.  Once I deleted the old 
versions it worked again.  Presumably it should have given a version 
error (or just magically worked correctly); it shouldn't have imported 
from the wrong version.

Not sure if setuptools should have caught that, or what.  Anyway, data 

Ian Bicking  /  ianb at colorstudy.com  /  http://blog.ianbicking.org

More information about the Distutils-SIG mailing list