[Distutils] setuptools 0.6a10 activation

Ian Bicking ianb at colorstudy.com
Wed Feb 15 00:15:49 CET 2006

I had a setup where I had a package "SampleApp".  It was installed once 
normally (as an egg), version 0.0.0dev_r3284.  Then I made a checkout, 
and ran "python setup.py develop" on the checkout.  easy-install.pth has 
/usr/iscape/web/aedemo/src/SampleApp in it, and SampleApp.egg-link 
points to the same place (with an egg-info directory and whatnot).  It 
was working fine.

Then we upgraded to 0.6a10 and the old version became the active 
version.  Confused me a bit; I ran python setup.py develop and it worked 

Actually, now that I think about it, I don't know what easy-install.pth 
looked like before I re-ran develop.  Hrm... and I lost the output of 
the develop command (if it had any useful information).  Anyway, I know 
it was working before we installed 0.6a10 (whether it should have or 
not), and broken after.

Damn installation problems... hard to reproduce.  Anyway, data point at 
least.  If I see it happen again I'll look more closely.

Ian Bicking  /  ianb at colorstudy.com  /  http://blog.ianbicking.org

More information about the Distutils-SIG mailing list