[Distutils] Problem upgrading docutils with setuptools

Phillip J. Eby pje at telecommunity.com
Wed Jan 25 19:14:13 CET 2006


At 06:46 PM 1/25/2006 +0100, Maciek Starzyk wrote:
>Is there a way to tell setup.py to do the equivalent of easy_install -m
>while upgrading its dependencies ?

No, not really.  You could always just bundle the "roman" module in your 
project, I suppose, or create a package for it on PyPI and make it a 
requirement of your project.  These approaches wouldn't change docutils' 
behavior, but it'd ensure that *your* projects using docutils would work.



More information about the Distutils-SIG mailing list