[Distutils] Namespace packages and egg-info confusion when using bdist_rpm

Ryan May rmay at ou.edu
Thu Aug 9 22:02:45 CEST 2007

> On Thu, July 26, 2007 2:01 pm, Phillip J. Eby wrote:
>> At 01:37 PM 7/26/2007 -0400, Stanley A. Klein wrote:
>>> I had the same error.  Should I have put in an "import enthought" in all
>>> the others?
>> No, apparently the manual import doesn't help.  Presumably the ones
>> you changed need something more like this:
>> import enthought; enthought.traits = sys.modules['enthought.traits']
>> import enthought.traits; enthought.traits.ui =
>> sys.modules['enthought.traits.ui']
>> I thought the import would be sufficient, but apparently it's not.  :(
>> Again, let me know if it works so I can change setuptools accordingly.

This solution worked for me initially, but now I'm getting warnings when
I run any python script I get:

warning: Not importing directory
'/usr/lib64/python2.5/site-packages/enthought/traits': missing __init__.py
warning: Not importing directory
'/usr/lib64/python2.5/site-packages/enthought/traits/ui': missing

This is when I added the above lines to the .pth files for both traits
and traits.ui.  What am I doing wrong?



Ryan May
Graduate Research Assistant
School of Meteorology
University of Oklahoma

More information about the Distutils-SIG mailing list