[Distutils] [Fwd: Re: [Enthought-dev] problem easy_installing kiva: agg.i missing]

Stanley A. Klein sklein at cpcug.org
Tue Aug 14 17:48:02 CEST 2007

FYI - The issues discussed here combine problems specific to the enthought
system with problems using setuptools (that are used if available for
parts of the packaging for Kiva).

---------------------------- Original Message ----------------------------
Subject: Re: [Enthought-dev] problem easy_installing kiva: agg.i missing
From:    "Stanley A. Klein" <sklein at cpcug.org>
Date:    Tue, August 14, 2007 11:46 am
To:      enthought-dev at mail.enthought.com
Cc:      "Dave Peterson" <dpeterson at enthought.com>

Dave -

I need to remove the files from the Kiva rpm for two reasons.

First, they don't belong in python/site-packages on a *nix system if
compliance with the *nix File Hierarchy Standard and/or the Linux
Standards Baxe (that cites the FHS) is desired.  If they are in the rpm
they need to go somewhere else.  I can fix that by declaring the docs
files in the setup.cfg file.  I tried that fix, although I don't know if I
did it correctly and it didn't resolve both problems.

Second, they are causing trouble in running the bdist_rpm because their
.pyc and .pyo files are producing an "installed but unpackaged files"
error.  That is somewhat peculiar to Fedora (and RedHat) because SE-Linux
needs to know what files are in sensitive directories or it may think they
might have been put there by an intruder and thus block access to them.
That problem may be due to the lack of __init__.py files (even blank ones)
in the relevant directories.  Setuptools apparently looks for __init__.py
files to guide its processing.  I could put in blank __init__.py files and
see what that does.

However, I would rather fix both problems (the packaging error and the
file placement) at the same time.  I figured the easiest way to fix the
problem is to get the directories out of Kiva and into somewhere else (a
Kiva docs directory that includes tests, examples, and docs).

I possibly need to go back, put in the blank __init__.py files in a lot of
places (the problem is inconsistent and I can't figure out why that
happens) and declare the docs as going into the proper FHS place.

Stan Klein

On Tue, August 14, 2007 8:58 am, Dave Peterson <dpeterson at enthought.com>

> Message: 1
> Date: Mon, 13 Aug 2007 20:23:31 -0500
> From: Dave Peterson <dpeterson at enthought.com>
> Subject: Re: [Enthought-dev] problem easy_installing kiva: agg.i
> 	missing

> Hi Stan,
> Unfortunately, I've never tried to do a bdist_rpm so I'm at a loss on
> what might be going on here.  But if I had to guess, I'm wondering if
> setuptools uses the .svn dirs for its build process -- these won't be
> updated by a local svn mv that hasn't been committed yet so it wouldn't
> surprise me that even doing an rm -rf wouldn't get rid of the record of
> them.  In fact, this seems like it would actively cause the error
> mentioned below -- you've removed the file but setuptools thinks they
> should exist since there is a record in svn.
> Why do they need to be removed from the rpm?
> -- Dave
> Stanley A. Klein wrote:
>> I svn-updated my enthought.branches/enthought.kiva.
>> The build worked.
>> I'm now back to having problems with unpackaged files and am working on
>> that issue, which is becoming very strange as well.
>> I have tried to get all the files not needed for Kiva operation out into
>> a
>> separate directory (called kiva_docs) at the enthought.branches level.
>> That includes the directories kiva/tests, kiva/agg/tests,
>> kiva/agg/examples, and kiva/agg/docs, plus some others that I also can't
>> seem to get rid of but don't seem to create the same error condition.  I
>> did an "svn mv".  I went in and did an "rm -rf" of the directories.
>> However, it seems that the files I thought I got rid of always seem to
>> keep getting found, included as files to be installed, and creating
>> problems with "installed but unpackaged files" error of rpm.
>> Stan Klein
>> On Mon, August 13, 2007 2:26 pm, Dave Peterson <dpeterson at enthought.com>
>> wrote:
>>  ------------------------------
>>> Message: 4
>>> Date: Mon, 13 Aug 2007 12:41:24 -0500
>>> From: Dave Peterson <dpeterson at enthought.com>
>>> Subject: Re: [Enthought-dev] problem easy_installing kiva: agg.i
>>> 	missing
>>> I'm curious if you've tried this on the latest unstable kiva?  The svn
>>> version is currently in branches and the source tarball is in the
>>> unstable dir.   I'm talking about enthought.kiva-2.0.0b2.dev here.
>>> -- Dave
>>> Stanley A. Klein wrote:
>>>> I'm having a very similar problem when I try to do "python setup.py
>>>> bdist_rpm" on kiva.  When I run "python setup.py build" it completes
>>>> properly.  The bdist_rpm creates an rpm spec file with the same
>>>> command
>>>> (or by adding an option I can make it the same command).  However,
>>>> when
>>>> the spec file runs, I get the error message about it not being able to
>>>> find agg_wrap.c.
>>>> My traceback (below) points to the error arising in the numpy
>>>> distutils.
>>>> I wonder if this has anything to do with setuptools being svn aware.
>>>> I
>>>> can imagine a possible cause being some anomaly in the embedded svn
>>>> information for kiva.
>>>> I hope this additional information helps.
>>>> Stan Klein
>> [remainder deleted]

Stanley A. Klein, D.Sc.
Managing Principal
Open Secure Energy Control Systems, LLC
8070 Georgia Avenue
Silver Spring, MD 20910

More information about the Distutils-SIG mailing list