[Distutils] Forcing setuptools options (always unzip, no dependencies) in buildout?

Jeff Shell eucci.group at gmail.com
Fri Dec 28 19:12:27 CET 2007

On Dec 28, 2007 8:40 AM, Jim Fulton <jim at zope.com> wrote:
> On Dec 28, 2007, at 9:30 AM, Jeff Shell wrote:
> > I still can't get a Egg based Zope app/site up and running.
> That's amazing.

I think that some of the problem stems from us using a lot of core
Zope 3 bits, and we have to take on some of the core ZCML
bootstrapping ourselves (zope.app.zcmlfiles doesn't cover everything
that we use). It was as I was going through this bit by bit that I
stumbled into the zope.filerepresentation issue.

Which I now realize is a non-issue! I just assumed it had a
configure.zcml like everything else. Since it was locked away in a
zipped egg and I was pressured for time, I never unpacked it to check
the contents. I think the issue stemmed from not including it as a
dependency, so an import failed. When I added the dependency, I then
blindly added an <include package="zope.filerepresentation"/> to my
app's site.zcml out of habit.

OK. I do have a new instance up now. It's a bit messily put together,
but I finally see that it can be done with our current software. I can
move forward!

> A while ago, I pointed you at some working buildouts that used Zope 3
> as eggs. Why not use those as starting points?

I did, and they helped. But just to get our core system up and running
required some different setups and dependencies that were a little
harder to figure out. And I ran into that zope.filerepresentation
non-issue right when I ran out of time.

Jeff Shell

More information about the Distutils-SIG mailing list