[Distutils] parallel package

Jim Fulton jim at zope.com
Fri Feb 2 14:18:39 CET 2007

Phillip J. Eby wrote:
> At 02:09 AM 2/2/2007 +0100, =?ISO-8859-2?Q?Micha=B3_Kwiatkowski?= wrote:
>> Going here works: http://python.org/pypi/parallel/0.2.1 .
>> Doing this doesn't:
>> $ easy_install parallel==0.2.1
>> Searching for parallel==0.2.1
>> Reading http://cheeseshop.python.org/pypi/parallel/
>> Reading http://cheeseshop.python.org/pypi/parallel/0.2.3
>> No local packages or download links found for parallel==0.2.1
>> error: Could not find suitable distribution for
>> Requirement.parse('parallel==0.2.1')
> easy_install -f http://python.org/pypi/parallel/0.2.1 parallel==0.2.1

Can this be automated?  It is annoying that PyPI hides
old versions from setuptools.  Perhaps the index API should
be expanded reflect that older versions can often be found
this way?  That is, perhaps setuptools should look at
INDEX_URL/PROJECT/VERSION when a version can't be
found another way.


Jim Fulton           mailto:jim at zope.com       Python Powered!
CTO                  (540) 361-1714            http://www.python.org
Zope Corporation     http://www.zope.com       http://www.zope.org

More information about the Distutils-SIG mailing list