[Distutils] Buildout not updating setuptools

Jim Fulton jim at zope.com
Thu Jul 5 14:51:40 CEST 2007

On Jul 2, 2007, at 8:08 AM, Graham Stratton wrote:

Sorry to take so long to reply.  I needed to find time to try to  
reproduce this.

> Hi, I'm having a problem with buildout.
> My system has setuptools 0.6c5 installed. The buildout bootstrap.py  
> script
> doesn't install the latest version,

No, It will use the existing setuptools installation if there is one.

> and nor does running bin/buildout. The
> result is that the Routes install fails with
> The required version of setuptools (>=0.6c6) is not available, ...

I tried to reproduce this, but was unable to.

> The problem seems to be that bootstrap.py creates a link for  
> setuptools in
> develop-eggs. Why would that be?

Is your existing installation of setuptools a develop egg?  Buildout  
always prefers develop eggs that satisfies a requirement, so if you  
started with a develop egg of setuptools, it won't be upgraded to a  
later version unless you specifially request one.


Jim Fulton			mailto:jim at zope.com		Python Powered!
CTO 				(540) 361-1714			http://www.python.org
Zope Corporation	http://www.zope.com		http://www.zope.org

More information about the Distutils-SIG mailing list