[Distutils] problem with setuptool install

Phillip J. Eby pje at telecommunity.com
Fri Nov 16 20:51:59 CET 2007

At 12:40 PM 11/16/2007 -0500, Tania Fahima Parvez wrote:
>I downloaded and installed the python-zlib rpm.  Stll the same result.
> >>> "Phillip J. Eby" <pje at telecommunity.com> 11/16/2007 11:36 AM >>>
>At 11:01 AM 11/16/2007 -0500, Tania Fahima Parvez wrote:
> >Hi,
> >
> >I downloaded the setuptools-0.6c7 version of setupttols.  I run
> >"python ez_setup.py" and it comes back with the following message
> >back: "Setuptools version 0.6c7 or greater has been installed."  I
> >have downloade the setupttols egg ( setuptools-0.6c7-py2.4.egg ) in
> >this directory also.  When I try to run the "python easy_install.py
> >setuptools-0.6c7-py2.4.egg" command , I get the following error in
> >the last lines:
> >  File
> > "/downloads/www.python.org/setuptools-0.6c7/setuptools/archive_util.py",
> > line 154, in unpack_zipfile
> >     data = z.read(info.filename)
> >   File "/usr/local/lib/python2.4/zipfile.py", line 353, in read
> >     raise RuntimeError, \
> >RuntimeError: De-compression requires the (missing) zlib module
> >
> >I have all the zlib libraries installed an in the path.
>Is there perhaps a "python-zlib" package provided by your OS?  That
>sounds like what's missing.

You mean, you still get "De-compression requires the missing zlib module"?

Try this:

    python -c "import zlib"

Does that work, or produce an error message?

(By the way, please direct your replies to the distutils-sig mailing 
list, as I don't do off-list support.)

More information about the Distutils-SIG mailing list