[Distutils] patches: ez_setup.py: don't import setuptools into your current address space in order to learn its version number

zooko zooko at zooko.com
Wed Oct 3 00:36:28 CEST 2007

> Okay.  Attached is a patch that doesn't import pkg_resources and  
> doesn't reload anything.  I haven't yet tested it -- I am  
> submitting it only to inform the discussion and get any early  
> feedback from you on whether the very idea is sound.

Okay, I tested this patch on Mac OS X and it worked.  First I  
installed setuptools v0.6c3, then I tried to execute allmydata.org 's  
"setup.py install".  I got the error message saying that it couldn't  
install a newer version of setuptools (v0.6c7) when an older version  
was already loaded.  Then I applied my patch to ez_setup.py and tried  
again.  This time it installed v0.6c7.



More information about the Distutils-SIG mailing list