[Distutils] error with bittorrent and twisted

Jean-Paul Calderone exarkun at divmod.com
Mon Oct 15 20:40:29 CEST 2007

On Sun, 14 Oct 2007 19:42:12 +0200, andy nicholson <intothemist at gmail.com> wrote:
> [snip]
>I get another error for Twisted :
>Searching for Twisted>=2.5
>Reading http://download.bittorrent.com/dl/
>Reading http://cheeseshop.python.org/pypi/Twisted/
>Reading http://twistedmatrix.com/
>Reading http://cheeseshop.python.org/pypi/Twisted/2.5.0
>Best match: Twisted 2.5.0
>Downloading http://tmrc.mit.edu/mirror/twisted/Twisted/2.5/Twisted-2.5.0.tar.bz2
>Processing Twisted-2.5.0.tar.bz2
>Running Twisted-2.5.0/setup.py -q bdist_egg --dist-dir
>usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
>   or: setup.py --help [cmd1 cmd2 ...]
>   or: setup.py --help-commands
>   or: setup.py cmd --help
>error: invalid command 'bdist_egg'
>Error: Subprocess exited with result 1 for project core
>error: Setup script exited with 1
>any hints?

setuptools is not compatible with Twisted 2.5: 


This could be fixed by making changes to Twisted's setup.py (as someone
has tried to do for #1286).  Other than this, I don't think there's
anything you can do to make it work.


More information about the Distutils-SIG mailing list