[Distutils] [Enthought-dev] Strange naming problem trying to build Enable rpm

Stanley A. Klein sklein at cpcug.org
Mon Aug 11 21:25:54 CEST 2008

[Oops.  Re-sent to fix the subject line]

Dave -

I wasn't using the release alias.  From what you say, I suppose I should.

I think the Enable project might be somewhat different from the others
because it uses both distutils and setuptools.

I will send you off line a program I used that fixes up the setup.cfg.

Stan Klein

On Mon, August 11, 2008 2:16 pm, enthought-dev-request at mail.enthought.com
> Message: 5
> Date: Mon, 11 Aug 2008 12:51:33 -0500
> From: Dave Peterson <dpeterson at enthought.com>
> Subject: Re: [Enthought-dev] Strange naming problem trying to build
> 	Enable rpm
> To: enthought-dev at mail.enthought.com
> Cc: distutils-sig at python.org
> Message-ID: <48A07C25.3010904 at enthought.com>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> Stanley A. Klein wrote:
>> I was able to build rpms for Traits, Envisage, and related packages (e.g.,
>> TraitsGUI) for Fedora 7.  However, when I tried to package Enable I ran
into the following problem:  The tar.gz gets built as
>> Enable-3.0.0.dev-r21092.tar.gz, but when the rpm packager gets called
it looks for Enable-3.0.0.tar.gz, doesn't find it, and errors out. 
I've copied a relevant part of the output below.
> I'm not sure what's happening here since the setup.cfg's for the ETS
projects should all be pretty close to the same on this issue.   Are you
doing a "setup.py release bdist_rpm"?  i.e. using the release alias?  If
not, that's the source of the problem.
> BTW: Are you checking in your changes to setup.cfg's?  If you don't have
privileges, I can make these changes so just send me a patch, set of
modified setup.cfgs, or instructions on what to do to reproduce your
> -- Dave

Stanley A. Klein, D.Sc.
Managing Principal
Open Secure Energy Control Systems, LLC
8070 Georgia Avenue
Silver Spring, MD 20910

More information about the Distutils-SIG mailing list