[Distutils] problem reinstalling easy_install

Phillip J. Eby pje at telecommunity.com
Tue Dec 2 20:36:38 CET 2008

Maybe somebody else on the distutils-sig has some idea, then.  I'm 
lost.  If I had to guess though, I'd check and see if maybe your /tmp 
directory has too many files or directories in it -- i.e., it seems 
like perhaps easy_install is trying to create a temporary directory, 
and failing before it can do anything else.  (Creating a temporary 
directory would be one of the very first things it does.)

At 01:59 PM 12/2/2008 -0500, dunia wrote:
>Phillip J. Eby wrote:
>>At 11:43 AM 12/1/2008 -0500, dunia wrote:
>>>I installed setuptools following the instructions at 
>>>http://peak.telecommunity.com/DevCenter/EasyInstall...but then i 
>>>realized that this package was in my repo (i'm using Debian sid). 
>>>I tried to undo my previous installation by removing from /usr/bin 
>>>and /usr/lib/python2.4/site-packages all setuptools 
>>>packages/files, and installed python-setuptools from the 
>>>repository without inconvenients. Now, when i try to use it, i get 
>>>the following error:
>>># easy_install -v ZopeSkel
>>>error: /tmp/easy_install-8zRT0t: Too many links
>>>Please, i'm stuck here, any hints will be much appreciated.
>>Is it the same error message each time (i.e. 
>>/tmp/easy_install-8zRT0t)?  Or does the directory name change each time?
>The error is always «error: /tmp/easy_install-<XXX>: Too many links» 
>where <XXX> is the part that changes.
>>Also, is there any text that appears *before* the "error:" line, 
>>but after you type in the command?
>The only text i get is the error i mentioned, there isn't any text 
>before or after.

More information about the Distutils-SIG mailing list