[Distutils] Setuptools + buildout for Zope 3?

Lennart Regebro regebro at gmail.com
Mon Dec 8 20:39:38 CET 2008


Well, I tried porting disutils to Python 3, and I got all the test
running, but somewhere along the path, I broke things, so now I get
the error

    zipimport.ZipImportError: not a Zip file:
'dist/setuptools-0.7a1dev_r66608-py2.5.egg'

When I try to actually *install* it. This I get on all versions of
Python, so I must have broken something when I changed the code so
that 2to3 would convert it happily. However, in the path of doing
this, I also have found bugs in 2to3, which means that I have to
massage some of the files by hand after the 2to3 conversion. So before
we can really start supporting Python 3 we need to get those bugs
fixed anyway. So that's the next part of this project.

I have however created a diff file with changes for distutils to stop
2.6 complaining when you run "python2.6 -3 setup.py test". I'll create
a bugreport with that diff soon.

-- 
Lennart Regebro: Zope and Plone consulting.
http://www.colliberty.com/
+33 661 58 14 64


More information about the Distutils-SIG mailing list