[Distutils] setuptools - what if a library is required but is in the standard lib?

Chris Withers chris at simplistix.co.uk
Thu Feb 7 17:55:31 CET 2008

Hi All,

If I mark my package as requiring wsgiref, will it still be downloaded 
if someone is using python 2.5?

If yes, how do I write my setup.py such that it's only required if the 
installer is using python 2.4 or less?



Simplistix - Content Management, Zope & Python Consulting
            - http://www.simplistix.co.uk
-------------- next part --------------
An embedded message was scrubbed...
From: Chris Withers <chris at simplistix.co.uk>
Subject: [Web-SIG] wsgiref for python 2.4?
Date: Thu, 07 Feb 2008 16:48:04 +0000
Size: 4199
Url: http://mail.python.org/pipermail/distutils-sig/attachments/20080207/03b1a5be/attachment.eml 

More information about the Distutils-SIG mailing list