[Distutils] [zc.buildout] building a testrunner

Jim Fulton jim at zope.com
Tue Jul 22 17:28:00 CEST 2008

On Jul 22, 2008, at 11:10 AM, Chris Withers wrote:
>>> Test-module import failures:
>>> Module: eggs.setuptools-0.6c5- 
>>> py2.4.egg.setuptools.tests.test_resources
>>> ImportError: No module named eggs.setuptools-0.6c5- 
>>> py2.4.egg.setuptools.tests.te
>>> st_resources
> Okay, taking just this first one:
> - why is the script trying to run setuptools' tests?

Ah, I totally miss-read your error messages. Sorry.

I have no idea.

> - why is it failing?

well, eggs.setuptools-0.6c5-py2.4.egg.setuptools.tests.test_resources  
is not a valid module name.  I have no idea were it is getting this  
module name.

> Both of these questions could also be applied just as equally to  
> zc.buildout, zc.egg.recipe, zope.interface and zope.testing.


>>> Test-modules with import problems:
>>> eggs.setuptools-0.6c5-py2.4.egg.setuptools.tests.test_resources
>>> eggs.setuptools-0.6c8-py2.4.egg.setuptools.tests.test_packageindex
>>> eggs.setuptools-0.6c8-py2.4.egg.setuptools.tests.test_resources
>>> eggs.zc.buildout-1.0.7_dev-py2.4.egg.zc.buildout.tests
>>> eggs.zc.buildout-1.1.0-py2.4.egg.zc.buildout.tests
>>> eggs.zc.recipe.egg-1.1.0-py2.4.egg.zc.recipe.egg.tests
> <snip>

Note, again, that these are not valid module names.  I have no idea  
where the test runner is getting these.

> It looks like the testrunner might be trying to find tests in the  
> egg cache?

<shrug>  Those aren't valid module names, so I have no idea what it's  

> Why would it do that?

Don't know. Must be a windows thing. ;)

I tried your buildout -- even on windows :) -- at it worked fine for  
me. The test ran find (with a test failure).  I suggest making sure  
your Python is clean.


Jim Fulton
Zope Corporation

More information about the Distutils-SIG mailing list