[Distutils] [issue24] Rename easy_install

James William Pye python at jwp.name
Fri Jun 13 18:17:07 CEST 2008

> On Jun 13, 2008, at 4:59 AM, Armin Ronacher wrote:
>> Currently the egg installation script is called "easy_install".  I  
>> would propose
>> to rename it to something like "pyegg" or something similar.   
>> Mainly because
>> "easy_install" is a very generic name and doesn't include anything  
>> related with
>> python in the name which causes confusion.
>> Additionally if easy_install gets an uninstallation feature the  
>> name is wrong too.
> -0 from me.
> While your reasons are good ones, Armin, it is too late to rename  
> easy_install.

+1 for a rename. Of course, start throwing a deprecation warning  
before removing
the command entirely. :(

More information about the Distutils-SIG mailing list