[Distutils] setuptools "tests" sprint today

Marius Gedminas marius at pov.lt
Thu Jun 26 22:57:06 CEST 2008

On Thu, Jun 26, 2008 at 11:54:16PM +0300, Marius Gedminas wrote:
> Same error with bzr 1.5, but I finally found the right URL:
>   bzr branch lp:~setuptools/setuptools-test/main
> Now, how do I run the test suite?  I see no scripts with suggestive
> names (such as test.py or runtests.py), setup.py test says there's no
> such command, nosetests aborts with a mysterious TypeError deep in its
> internals.

I tried ./setup.py test again, and it worked.  Apparently it needs
python-setuptools installed in my system Python, which I got as a side
effect of apt-get installing python-nose.

All 55 tests pass here.

Marius Gedminas
(mental note: stop installing red hat. everytime i do so, it takes ages to fix
my system again.)
                -- from the sig of Martin Högman
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20080626/e1978647/attachment.pgp>

More information about the Distutils-SIG mailing list