[Distutils] [pyconuk] "just use debian"

Tarek Ziadé ziade.tarek at gmail.com
Tue Sep 30 14:05:08 CEST 2008


On Tue, Sep 30, 2008 at 10:42 AM, Nicolas Chauvat
<nicolas.chauvat at logilab.fr> wrote:
> For example, if you require a minimal version of 1.4, you can
> translate this to a package version of 1.4; it is a bit hackish but
> will work if you handle epochs correctly. But if the package you
> depend on has a Provides: blah (1.4), you have no way to map that to a
> dependency, because you can't know what other versions of the package
> will provide.

I am not sure to fully understand, could you provide a real-word example ?

>
> In all cases, it will be necessary to manually add shlibs-like
> information to the packages; they could be partly autogenerated like
> symbol files, but you need a mapping between provided modules and the
> first version of the package that provides it.


Is this related ? http://lists.debian.org/debian-dpkg/2006/01/msg00118.html


More information about the Distutils-SIG mailing list