[Distutils] Problems installing Easy Install/Setup Tools (segmentation fault)

Niklas Bivald niklas at bivald.com
Tue Jan 20 08:25:44 CET 2009


Dear peak,
I've been tearing my hair out on a installation issue I've been  
having. I've searched Google, I've searched the archives. I've been  
running setuptools on my OS X box for quite a while and it's been  
working great. However, moving on to my Debian (production) box has  
cause me considerable problems. It may be a Python issue, but I've  
tried Python 2.4, 2.5 and 2.6 (and 2.6.1) and I keep getting the same  
error. Hopefully I've just missed something easy.

I've tried to install setuptools using apt-get without luck (gives me  
a non-describt error about failed installation) and using eggs:

chat4:/home/orbited# sh setuptools-0.6c9-py2.6.egg
Segmentation fault

gives me segmentation fault. I've switched to using from source in  
order to catch the exact error, and I've boiled it down to:

chat4:/home/orbited/setuptools-0.6c9# 	python2.6 -dv easy_install.py  
install
[...] Quite a long output [...]
# /home/orbited/setuptools-0.6c9/setuptools/dist.pyc matches /home/ 
orbited/setuptools-0.6c9/setuptools/dist.py
import setuptools.dist # precompiled from /home/orbited/ 
setuptools-0.6c9/setuptools/dist.pyc
Segmentation fault

On Python2.6, 2.5 and 2.4. Verifying the problem on 2.5:

chat4:/home/orbited/setuptools-0.6c9# python
Python 2.5.2 (r252:60911, Jan  4 2009, 17:40:26)
[GCC 4.3.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
 >>> import setuptools.dist
Segmentation fault

On 2.6:

chat4:/home/orbited/setuptools-0.6c9# python2.6
Python 2.6.1 (r261:67515, Jan 20 2009, 07:59:19)
[GCC 4.3.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
 >>> import setuptools.dist
Segmentation fault

I  must be missing something vital, using more debug flags gives me:

import setuptools.dist # precompiled from /home/orbited/ 
setuptools-0.6c9/setuptools/dist.pyc
# trying /home/orbited/setuptools-0.6c9/setuptools/depends.so
# trying /home/orbited/setuptools-0.6c9/setuptools/dependsmodule.so
# trying /home/orbited/setuptools-0.6c9/setuptools/depends.py
Segmentation fault

Can anyone think of anything that would share some light on this issue?

Regards,
Niklas


More information about the Distutils-SIG mailing list