[Distutils] imho Distutils should stop this from happening to poor users....

Tarek Ziadé ziade.tarek at gmail.com
Thu Jun 18 10:45:58 CEST 2009

On Thu, Jun 18, 2009 at 10:26 AM, David Lyon <david.lyon at preisshare.net>wrote:

> Hi All,
> Here's a package installation error message that's just plain scary
> for the average user.
> imho Distutils should have checks to stock packages requiring a C
> compiler from being uploaded. It isn't "right" to expect that
> from users. ie They should get the .pyd files.

That's not distutils fault, neither easy_install one.

"appscript" should provide a binary distribution for Windows (it does for
Mac OS if you look at the pypi repo)
Since it doesn't, easy_install grabs the source distro, which is the best
behavior I can think of,
then tries to compile it.

The error message is pretty explicit by the way

Tarek Ziadé | http://ziade.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/distutils-sig/attachments/20090618/bde0dec4/attachment.htm>

More information about the Distutils-SIG mailing list