[Distutils] zc.buildout bootstrap errors

Tres Seaver tseaver at palladion.com
Mon Nov 2 23:57:00 CET 2009


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jim Fulton wrote:
> On Mon, Nov 2, 2009 at 2:32 PM, Tres Seaver <tseaver at palladion.com> wrote:
>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA1
>>
>> Why would a "bootstrap" fail due to missing / less-than-required version
>> of setuptools in the host python?  The bootstrap should be
>> self-contained enough to make things work no matter what, since the
>> point is too build an environment which doesn't rely on anything beyond
>> a "bare" Python install.
>>
>>  $ svn co $ZSVN/Acquisition/trunk Aq-trunk
>>  ...
>>  $ cd Aq-trun
>>  $ /path/to/python2.6 bootstrap/bootstrap.py
>>  The required version of setuptools (>=0.6c11) is not available, and
>>  can't be installed while this script is running. Please install
>>  a more recent version first, using 'easy_install -U setuptools'.
> 
> This is probably due to an attempt to use an existing setuptools if
> it's available.  I could probably add an option to get it to not do
> that. I'll look into that.

Great, thanks.  I can see re-using that version if it is present, and
new enough, but we ought to be able to use a downloaded version if that
fails.


Tres.
- --
===================================================================
Tres Seaver          +1 540-429-0999          tseaver at palladion.com
Palladion Software   "Excellence by Design"    http://palladion.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkrvY7wACgkQ+gerLs4ltQ7HtwCfaVVBBg5Ti87BTgc7WjmdX19+
u7cAoICgsoFUVWS4rAdjhGQCp+zyfQ4e
=hKL9
-----END PGP SIGNATURE-----



More information about the Distutils-SIG mailing list